FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
Back to site

Hall sensor failure

 
Post new topic   Reply to topic    EFI University Forum Index -> MoTeC
View previous topic :: View next topic  
Author Message
snax



Joined: 18 Apr 2008
Posts: 2

PostPosted: Tue Nov 29, 2011 8:34 pm    Post subject: Hall sensor failure Reply with quote

Pantera GT5-S
Amerisport twin supercharged
351c
M48 ECU
437-DTM cam sensor

Im working on the above car, customer complaint was a no start after stalling at a stop light. I was able to get the car started and running after adding more fuel with the cranking pulse width. Once the car is up to temp it once again becomes very difficult to start and will backfire out of the exhaust after 7-8seconds of cranking, it will also throw a sync error at that time.

I scoped the cam and crank sensor signals at the m48 ecu and attached the following image with the results. Blue trace is crank signal and red is cam or sync. normally I would just replace the cam sensor with another motec 437 and send the car down the road but the placement of this sensor has me wondering whats is the cause of the failure.

From what I understand they drilled and placed a magnet on the fuel pump eccentric of the camshaft and built a holder for the sensor to go in place of the mechanical fuel pump. I removed the holder and sensor to take a look at it and found the sensor is not sealed from engine oil splash, the entire sensor is wet with oil and it looks like it has seeped past the heatshink into the back side of the sensor itself.

Would that cam sensor trace below be caused from oil shorting out the reference voltage to the signal wire? I dont want to just replace the sensor if the oil splash will just damage another sensor, I have also read on the motec forums that the 437 sensor is only good for about 50c temp wise?

The twin superchargers and complex belt drive prevent me from dropping a cam sensor into the distributor hole so I will have to get creative If I want to do something different with the setup.


Back to top
View user's profile Send private message
Pantera EFI



Joined: 12 Feb 2005
Posts: 1718
Location: So. California

PostPosted: Wed Nov 30, 2011 6:00 am    Post subject: Pantera EFI Tech Reply with quote

I can state that in a Best In The Desert race the "Vegas to Reno" event, a WET race, several Motec users lost CAS in the race because of the rain water.
My guess is the sensor design was the same as yours, from JGM.

I would switch the sensor manufacture or model.

WE do not require a CAS to allow the EFI on a Pantera to operate, if it fails AND the coils are "set for waste sparkl", (all eight of one) the engine will run fine.

The above statement is NOT "BASHING"

The reason is that we use a "missing tooth" Crankshaft Target Wheel.

When the M48 has the current Firmware that mode could be used if a CT of 24x, 36x, or 60x was fitted.

This could be the solution, to cut the stranded car case in half.


Lance
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    EFI University Forum Index -> MoTeC All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

©2007 EFI University
Website designed and maintained by 3LizardsMedia.com